Menu Windows

From DXLog.net
Jump to: navigation, search

Contents

Worked Zones

Shortcut: ALT+Z

Zones.png

Worked zones window. The title of this menu item will fit to the chosen contest. The window displays the worked multipliers (in blue) or not (in white) on the current band, and possibly the current mode.

Zones ab.png

Also ff the contest is multi-bands and/or multi-modes, you can display the distribution of these multipliers by band (and/or mode). To change to by band, right mouse click on the zones window for the context menu and select all bands.

Zones rc.png

Right mouse click on the zones window for the context menu.

Zones window can be copied as an image to save for later use or paste into an email from the context menu.

Worked DXCC

Shortcut: ALT+M

Dxcc.png

If one DXCC country has been worked on a band (possibly a mode), this band will be displayed in blue, otherwise it remains in white. This window is resizable.

Continents are selected from the radio buttons at the top of the screen.

All the data included in this window can be copied as a text file, and pasted in text or directly in an OpenOffice spreadsheet, for a later analysis from the right mouse click context menu.

DXCC expected and spotted information is also available on this window. The colors used for this information are selectable on the right click context menu Colors.

Dxcc rc.png

Worked gridsquares

Shortcut: ALT+L

Note: this selection will only be available if the current contest uses Gridsquares as multipliers.

Gridsquare map.png

Right click on the map and select Properties to open the settings form:

Gridsquare map properties.png

This form allows customization for your particular area and contest.

Check callsign

Shortcut: F9

Band check.png

This window displays a checkmark if and on which bands a specific callsign has been logged before. Depending on the type of the contest, the display may show more than one column to display the different possible modes.

Check multipliers

Shortcut: F10

Check mult.png


When a callsign or country prefix is entered in main logging window this window will indicate whether this multiplier has been worked or not on the current (highlighted by a blue line) or other bands (and in other modes if the contest rules permit). If the callsign entered has been worked on other bands, DXlog.net displays those QSOs. Otherwise, the callsign of the first station worked in that multiplier on that band is displayed, if any.


Additional information about the multiplier is displayed at the bottom:
The official country prefix and country name.
The short (Az) and long path (Lp) beam headings (azimuths) to this multiplier (based on the station locator entered in the Contest configuration screen)
The sunrise (SR) and sunset (SS) time in this country, expressed as UTC (suffixed by a lowercase "z"). These times are computed from the geographical coordinates given taken from the CTY* file or your QTH locator, if specified in the setup dialog.

Check partials

Shortcut: F12

Check part.png

Check partial callsign search window, When at least 3 characters are entered in the log call entry field, DXlog.net Check Partial looks in the master database for the callsigns including the 3-character string.

In the above example M0C was entered into the log call entry field and the Check Partial database search found all the callsigns with the 3 characters in that order and displayed those.

A callsign can be moved to the log call entry field by double clicking on the callsign in the Check Partial window.

White callsigns are those not yet in the log, green callsigns are stations worked on another band, but not the current band and red callsigns are dupes.

Check part rc1.png

Right mouse click on the window shows the context menu.

Search can be activated after 2 characters entered into the log call entry field by ticking the option in the context menu.

Search can be limited to the current log data only by ticking the "in log only" option in the context menu.

Show data from prefil database option will pull the relevant data from the prefil database and display next to the callsign in (), this is useful for VHF / UHF contests and locator squares

Check part pfd.png

Check N+1

Shortcut: F8

N+1.png

N+1 window, when at least 3 characters are entered in the log call entry field, DXlog.net looks in the master database for callsigns differing from the partial callsign by one character.

N+1 also detects a 2-character swap (dyslexia), as well as one missing character.

A callsign can be moved to the log call entry field by double clicking on the callsign in the Check Partial window.

White callsigns are those not yet in the log, green callsigns are stations worked on another band, but not the current band and red callsigns are dupes.

N+1 rc.png

Right mouse click on the window shows the context menu.

Search can be limited to the current log data only by ticking the "in log only" option in the context menu.

Summary

Shortcut: ALT+S

Summary.png

The summary window displays the number of QSO (which does not include the dupes), along with multipliers relevant to the contest type for each band in the blue section, with the dark blue strip showing the current band being operated.

Grey section at the bottom shows totals for the contest and final raw score.


Summary rc.png


The right mouse click context menu allows you to copy the scoring summary data in the clipboard as an image or as a text file.

Rate

Shortcut: ALT+R

Rate.png

Rate data information window displays live qso rate data relating to the current contest.

Top section shows QSO's in last hour, last 10 rate, last 100 rate, rate since last time hour passed and if selected in the context menu, a projected score.

Second section shows time on and time off in hours and minutes.

Third section shows differential between run and s&p mode.

Fourth section shows time since last mult, mult and qso points worth.

Fifth section shows operating mode and if in CW the CW send speed


Rate rc.png

Right click context menu allows you to set Target QSO's / Hr, global QSO rate and add a calculated projected final score.

Rate ru.png

Right click context menu and Rate units allows you to set the rate unit display type.

Operating info

Operating info.png

Operating info window displays the radio active mode, if in SO2R it will display Radio 1: and Radio 2:

The CW repeat timer interval and the CW speed set in DXlog.net.

If you have interlocks active, the interlock status will be shown in the Operating info window. Interlock blocking can be forbidden by clicking on the Interlock status line. The status will change to 'Blocking forbidden' as shown below.

Interlocks can also be controlled by the $PILOCK (forbid) and $AILOCK (allow) macros.

Operating info blocking forbidden.png

Statistics

Shortcut: CTRL+F9

Gab

Shortcut: ALT+I

Gab.png

Gab window displays all the chat between networked stations. In the context menu, the option "Save history to file" allows all the gab chat to be recorded in the .gab file of the current contest. A double-click in a station name in this window will open the chat dialog, with this station name as default destination.

To send a message use Shortcut: ALT+G and the chat entry window will appear.

Chat.png

Type a message and select either the individual station you wish to message or all to message all networked computers then click ok

Gab window context menu - right mouse click on gab window.

Gab rc.png

Status window

Shottcut: ALT+J

Status.png

The status window indicates the status of each station connected to the network. From left to right, are displayed : Station name, Current band and mode, Station type, QSY frequency of the current band and mode, Radio 1 frequency, Radio 2 frequency, Time left before a possible QSY, according to the 10 minutes M/S rule, or "OK" if the station is allowed to make a QSY on another band (only appears if the contest specifies this particular rule). Your own station is displayed in a deep blue background. The active radio of each station has its frequency in red characters. A double left click on a station name will display the chat dialog with this station name as default destination. A double left click on any frequency displayed will tune the current radio to that frequency.

Open the context menu by right mouse clicking in the window.

Status rc.png

The Station name may be changed in Options -> Configure Network even if networking is disabled.

QSY Wizard

The QSY Wizard can only be used if HamCAP is installed and running. You must also have Options | HamCAP | Tab set to Charts.

After entering a callsign into the log callsign entry field, pressing Ctrl-P will bring up the HamCAP window with a propagation prediction to this station. Then, the QSY Wizard will display the bands on which to which a QSY or sked may be useful

Qsy wiz.png Qsy wiz hamcap.png

In the above example ZS6TX has been worked on 20m. After pressing Ctrl-P the wizard tells us that a QSY may be promising on 15m. For 10, 40, 60, 160m however, the wizard recommends a sked time instead. This is the peak time predicted by HamCap for this path, hovering the mouse curser over the yellow square on the Hamcap chart will give more information including the MUF and signal elevation etc.

Each band line is shown in a different color if the multiplier is needed on the band. The colors are selectable on the right click context menu Colors.

If a mult station is available on the band, the line will be marked with a different color. Clicking on a band line brings up the Pass A Station window filtered on the clicked band. This action can be enabled/disabled by checking/unchecking the "Options->Networking->Show QSY notification in QSY Wizard" option.

Extra Information

Extra info window.png

The Extra Information window displays information contained in a text file based on the call entered in the log callsign entry field. Files should be named with the .xdt file extension.
The format of the Extra information file is:

 #TITLE Name of info
 K6MR Ken 1270 CA    (typical data line)

The text on the #TITLE line will be shown on the header line. If the #TITLE line is omitted, the complete path and filename will be shown. Data lines (one per call) begin with the call sign and a single space. Any information present after the first space will be shown exactly as formatted in the file.
Multiple files may be opened at the same time to show data from different sources.

If a file is updated while open in the window, right click and select "Reload files" to use the new data.

Partner

Partner.png

This feature is especially useful in a Multi-OP environment when facing large pile-ups and/or weak signals.

Set up a second operator as support with a second computer which has DXlog.net installed and a pair of headphones connected to the receiver, on both comptuers open up the Partner window.

The running operator continues as before,working the callsign he hears. The support operator listens at the same time and tries to copy additional callsigns from the pile-up by entering the callsign on the QSO entry field and then pressing Alt-Enter.

This callsign will now be displayed in the Partner Window stack for the running operator to use as his next contact

The Partner window can hold up to 9 callsigns, and theses calls can be pulled into the callsign field with Alt-(1-9). Once the QSO is logged, that callsign will disappear from both partner windows.

The Partner can remove a callsign if incorrect or no longer valid using Alt-(1-9).

A field in the partner window can be overwritten by a new entry by pressing Ctrl-(1-9).

The Partner window is also useful when used in a RTTY environment.
In addition to using the Ctrl-(1-9) and Alt-(1-9) keys as previously noted, calls may be entered into the stack by selecting a call in the rtty receive window using the mouse pointer.
Two callsign selection methods are available:

 Alt-LeftClick (left mouse click while holding down the Alt key)
MiddleClick (a scroll wheel click on most mice)

Subsequent selections in the rtty receive window will populate the next empty line in the Partner window.

To place calls from the Partner window stack into the active QSO line, the $GRABPARTNER variable is used in a macro message to grab the first call from the Partner window stack.
Typically this can be used in a special TU message to confirm the current qso, enter the next call, and send the report:

 $13 $CORRECT TU $GRABPARTNER NOW $LOGGEDCALL $F2 $CR


Radio/Ant status window

Radio ant status.png

Radio/Ant status info window

If you are using a MK2R/MK2R+/u2R, OTRSP device or LPT port to control your antenna selection, this window will show the status of that interface.

The antenna names, select codes, and band selection must be set up using the appropriate configuration page:

 MK2R/MK2R+/u2R: Options->MK2R/MK2R+/u2R configuration.
 OTRSP: Options->OTRSP device configuration.
 LPT: Options->Configure interfaces->Printer port Setup.

If you wish to select a different antenna between RX and TX this must be enabled using:

 Options->Interface specific options->Allow different RX/TX antenna

Note: Separate RX/TX antenna selection is not available when using the LPT port.

Only antennas defined for the band that is active on each radio will be shown. The selected antenna on each radio will be highlighted. When changing bands, the antenna defined first (for that band) on the interface will be selected.

There are two methods of selecting an antenna:

 1. Alt-F11 (RX Ant) and Alt-F12 (TX Ant). If the separate RX/TX antennas option is not enabled, either key combination will select both the RX and TX antenna.
 2. Select the antenna by clicking on the required antenna in the Radio/Ant status window using the mouse. 

Note: the separate RX/TX antenna selection will only work when DXLog.net is controlling RX/TX switching, such as when it is sending messages. To enable RX/TX antenna switching when keying manually you must provide a PTT signal to enable RX/TX antenna switching.

World Map

Map.png

World map showing Daylight, Greyling and Night.

World map context menu is available by right mouse clicking on the map window. Grey line display options can be adjusted from this menu.

Map rc.png

Map size can be increased by using the zoom in option in the right click menu.

Radio 1

Radio1.png

Radio information displaying VFO A and VFO B frequency information.

Single click on VFOA or VFOB to change focus to this VFO.

Band map tab shows radio band in focus and any DX Cluster received or locally entered callsigns plus other optional information.

List tab shows a list of call signs which can be sorted in various ways.

Colours are:- RED = Double Mult, GREEN = Mult, Black = Unworked, GREY = Worked

Information below the horizontal divider is available mult numbers, available QSO's and points available.

Double clicking on a callsign sets the focus radio VFO to that frequency (and in split mode if information available from split DX Cluster spot) and puts the callsign into the log callsign field. This can be changed to a single click by selecting the enable single click selection from the context menu.

A right click anywhere in the Bandmap will bring up the context menu. Bandmap options are changed by selecting the appropriate menu.

Bandmap context menu.png

Most menu picks are self explanatory.

Show from higher to lower frequency The default bandmap display is to show lower frequencies at the top, higher frequencies at the bottom. As you tune up the band, the bandmap will move up as the cursor points to a higher frequency. If you would prefer that the bandmap show higher frequencies at the top (with resulting movement down as you tune up the band), check this option. This option may be changed at any time and the bandmap will redraw automatically.


Radio1 rc so.png

In list mode the data can be sorted in a number of ways from the context menu and sort

Radio1 rc do.png

Display options for both Band Map and List mode are set from the context menu and display options

Radio1 rc pr.png

Various properties can be set by a right mouse click in the bandmap and selecting Properties.

Bandplan Settings for Bandplan spots to be displayed are set from the Properties form. Select Setup in the Bandplan section of the Properties form to display the current Bandplan settings. The current band will be displayed by default. Be sure to save your changes to the appropriate Bandplan memory (Default or Bandplan 1 - Bandplan 9).

To edit a different Bandplan than the one currently active, select the Bandplan button under Load. If a Bandplan has no settings, the Load Bandplan n button will be greyed out. To use a new Bandplan memory, save the current settings to a new memory. Then edit as necessary and save the new bandplan using the appropriate Save As button.

If you wish to activate a new or different Bandplan for the current log, check the box in the lower left corner of the form.

Note: If the spot mode is included in the spot comment, the spot will be displayed using the mode shown in the comment. Otherwise the mode will be determined by the active Bandplan.


Radio1 rc pr bp.png

Radio 2

Radio 2 is as per Radio 1 but for SO2R mode when 2 radios are connected to the one instance of DXlog.net

Digital Decoder Windows

There are four digital decoder windows (two for each radio), each enabled by selecting separately from the Windows menu.
The four selections are located just below the Radio1/Radio2 band map menu picks, and the exact wording is dependent on the RTTY Configuration.

IMPORTANT: Radio 2 windows will only be active if SO2V, SO2R or Advanced SO2R are enabled in Operating > Technique.

Data radio menu.png

Before using the decoder windows, they must be configured using the RTTY Configuration form: Options-> RTTY Configuration

RTTY Config.png

After configuration, each decoder window menu selection will show which decoder has been configured, for each selection (Primary/Secondary) and radio (Radio 1/Radio 2). Note that the Primary decoder is the decoder used for the transmit interface, usually MMTTY.

Selecting the appropriate menu pick will open the decoder window. The Primary decoder window will display a set of clickable buttons at the bottom that duplicates all message function keys. The Altx buttons provide access to the messages defined in the Alt-C (Other Messages) form. In addition, there is an Alt-K button (open keyboard mode window) and a (C) button (clear decoder window).

RTTY R1.png RTTY R1R.png

When the decoder windows are opened the first time, it will be necessary to configure each one for input and output parameters such as sound card, FSK port, etc. These settings will be saved by the decoder program and only need to be configured the first time.

Note: MMTTY will only save the FSK port settings if you close the MMTTY windows before closing DXLog.net. If you let DXLog.net close the MMTTY windows the FSK port will reset to NONE and will need to be selected at the next use.

MMTTY.png
Example of MMTTY engine window.

DX-Cluster monitor

Shortcut: ALT+O

Dx cluster monitor.png

Floating window displaying live information from the connected DXCluster as received.


Right mouse click on the window for context menu.

Dx cluster monitor rc.png

Stream logging - if checked, will save last 500 lines of DXCluster monitor window to temp file. File will be read on a restart to restore data.

Show network stream - if more than one networked PC is in use, and you run a connection to DXClusters on more than one of the PC's in the network, checking this option will show data from all DXCluster connections in the DXCluster monitor window, but with different color.

DX-Cluster announcements

Shortcut: ALT+A

Dx cluster announcement.png

Floating window showing received DX Cluster spots with total valid spots for Mult QSO's, Standard QSO's and Total QSO's per band at the top of the window

Double left click the mouse on a spot to tune connected radio to this frequency and auto enter the callsign into the log callsign entry field.

Spots displayed can be set manually per band or any number of bands or automatically from the connected radio band data, or display just multipliers, user can set by right clicking the displayed bands window and selecting from the context menu that appears.

Dx cluster announcment 1.png


Information displayed in the window can be filtered using the context menu and selecting display options.

Dx cluster announcment 2.png


Incorrect spot callsigns can be modified by right clicking the callsign and selecting modify from the menu.

Spot mod.png

Spots can be deleted by right clicking the callsign and selecting Delete.

Context menu is available by right mouse clicking on the dx cluster announcements window.

Clock

Clock.png

Time information bar, including Sunrise and Sunset times and the active station callsign.

When the time is coming up to the hour the clock will turn dark red, when the time is on the hour the clock will be red (If default colours are used).

When the SR and SS times are close the SR and SS times will turn dark red, When SR and SS times are reached the times will turn red (If the default colours are used).

Left mouse click and drag to move.

Right mouse click on bar for context menu.
Fonts and colours can be set from this menu.
Clock rc.png

When Tools > Data entry > Enable run / SP switching is enabled the Clock bar will show the mode of operation, in Run mode the clock background is grey but in S&P mode the Clock bar background is yellow (If default colours are used).

Clock bar in run mode.
Clock1.png

Clock bar in S&P mode.
Clock2.png

Contest Recorder

Contest recorder.jpg

The contest recorder allows you to record both main and sub VFO audio for the whole contest in MP3 format onto your PC hard disc.

If you want to record using DXLog, you have to download libmp3lame.dll win32 version from [1].
Win32dll.jpg
Note that the 64 Bit DLL version definitely does not work on Windows 7 64 Bit systems.

Extract the dowloaded archive file into DXLog.net installation folder.
For 32 bit Processors this is usually ..\Program Files\DXLog.net
For 64 bit processors this is usually ..\Program Files(x86)\DXLog.net

Before recording, see Options->MP3 config to set parameters which fits to your PC sound card setup.

Encoding rate is currently fixed to 32000 kHz, stereo, 96kbps which is more than adequate for good recordings with a reasonable file size.

Recording levels are set in the Windows Recording Devices of your PC, strongest signals should peak top yellow on the Contest Recorder bar graph display for best results.

To playback, select the qso in Dxlog you wish to hear, either by searching for the QSO number or manually using the up down arrows, then right click on the contest recorder and select PLAY QSO. For more playback options use the contest recorder right click context menu:-

Contest recorder rc.png

[1] - Link to libmp3lame.dll download

SSB Bargraph

SSB Bargraph.png

Bargraph showing output of recorded files for Function Keys.

Drag to move

Right mouse click on bargraph for context menu.

SSB Bargraph rc.png

Personal tools
Namespaces
Variants
Actions
Navigation
Toolbox